using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"M[a-zA-HJ-NP-Z0-9]{12,15}";
string input = @"MMMMMMMMMMMMMM
M1234567890123
coucou MMMMIMMMMMMMM
coucou MMMMOMMMMMMMM
coucou MMMM10MMMMMMMM";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}