$re = '/M[a-zA-HJ-NP-Z0-9]{12,15}/m';
$str = 'MMMMMMMMMMMMMM
M1234567890123
coucou MMMMIMMMMMMMM
coucou MMMMOMMMMMMMM
coucou MMMM10MMMMMMMM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);