package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\/\n\?\=]+)`)
var str = `https://www.googlekk.kk.com/jkjkjj/jkjhkj/bmnbm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}