re = /^(?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\/\n\?\=]+)/mi
str = 'https://www.googlekk.kk.com/jkjkjj/jkjhkj/bmnbm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end