$re = '/(?=\S.)({|})/m';
$str = ' {
"name": "Whatever",
"entries": [
"If something something {28} + {41.6} something"
]
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);