re = /(?=\S.)({|})/m
str = ' {
"name": "Whatever",
"entries": [
"If something something {28} + {41.6} something"
]
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end