use strict;
my $str = 'HYD. CYLINDER
HYD CYLINDER
HYD.CYLINDER
HYDRAULIC CYLINDER
CYLINDER,HYD.
CYLINDER,HYDRAULIC
CYLINDER,HYD
CYLINDER, HYD.
CYLINDER, HYDRAULIC
CYLINDER,HYD
';
my $regex = qr/\bhyd(?:\.|\b)([a-z0-9]?)/ip;
my $subst = 'HYDRAULIC ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";