re = /\bhyd(?:\.|\b)([a-z0-9]?)/i
str = 'HYD. CYLINDER
HYD CYLINDER
HYD.CYLINDER
HYDRAULIC CYLINDER
CYLINDER,HYD.
CYLINDER,HYDRAULIC
CYLINDER,HYD
CYLINDER, HYD.
CYLINDER, HYDRAULIC
CYLINDER,HYD
'
subst = 'HYDRAULIC '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result