package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(#\h*)((\[\d+]|\{\d+}|\(\d+\))(?:\h+(?3))*)$`)
var str = `# [1] {1} [2] {10} [3] [3] [4] {10} {100} [1] [5]
# [5] {1} [6] (10) (20) (10) {10} [7] [5] [6] {10} {100} [8] [5] (10) (30)
# (10) (30) [7] {1} [8] {10} [9] [7] [8] {100} {101} [9] [5] {101} (50)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}