const regex = /^(#\h*)((\[\d+]|\{\d+}|\(\d+\))(?:\h+(?3))*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(#\\h*)((\\[\\d+]|\\{\\d+}|\\(\\d+\\))(?:\\h+(?3))*)$', 'gm')
const str = `# [1] {1} [2] {10} [3] [3] [4] {10} {100} [1] [5]
# [5] {1} [6] (10) (20) (10) {10} [7] [5] [6] {10} {100} [8] [5] (10) (30)
# (10) (30) [7] {1} [8] {10} [9] [7] [8] {100} {101} [9] [5] {101} (50)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}