$re = '/^(?=.{8,})(?=.*?\d)(?=.*[\s!\"#$\%&\'\(\)\*\+\,\-\.\/\:;<=>?@\[\\\\\]\^\_\`\{\|\}\~])(?=[a-zA-Z0-9].*?[a-zA-Z0-9].*?[a-zA-Z0-9].*?).*$/m';
$str = 'od%57wubWF
hello
bruh
Pa55W0&rd
efouebfefee
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);