re = /^(?=.{8,})(?=.*?\d)(?=.*[\s!\"#$\%&'\(\)\*\+\,\-\.\/\:;<=>?@\[\\\]\^\_\`\{\|\}\~])(?=[a-zA-Z0-9].*?[a-zA-Z0-9].*?[a-zA-Z0-9].*?).*$/m
str = 'od%57wubWF
hello
bruh
Pa55W0&rd
efouebfefee
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end