re = /(\${)(\w+)(\$?})\1(\w+)\3/
str = 'anything text1${text2${text3}${text4}text5} anything'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end