$re = '/^\S+\.(?:(?:\(%\)|\[%\])%?)?$/m';
$str = '19.(%)%
19.[%]%
19.(%)
19.
abc.(%
abc.)%
abc.(%]
abc.)%]
1abc9.(%[
abc.)%[
abc.(%(
abc.)%)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);