re = /^\S+\.(?:(?:\(%\)|\[%\])%?)?$/m
str = '19.(%)%
19.[%]%
19.(%)
19.
abc.(%
abc.)%
abc.(%]
abc.)%]
1abc9.(%[
abc.)%[
abc.(%(
abc.)%)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end