const regex = /.*\Ks.t/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\Ks.t', 's')
const str = `asas s1t xvxvxcv s2t sfsfg s3t xvxcvv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}