$re = '/.*\Ks.t/s';
$str = 'asas s1t xvxvxcv s2t sfsfg s3t xvxcvv';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);