#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^<!--\s*dbox:(.+?)\s*-->$|^.*dbox:(.+?)\s*$)"
Local $sString = "<!-- dbox:/temp/rosemary.txt -->" & @CRLF & _
"rosemary macphail"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")