$re = '/(?:^<!--\s*dbox:(.+?)\s*-->$|^.*dbox:(.+?)\s*$)/m';
$str = '<!-- dbox:/temp/rosemary.txt -->
rosemary macphail';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);