const regex = /\/\*\*\s*\n\s\*\s@ngdoc method\n(\s\*.*(?<!methodOf)\n)*\s\*\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*\\*\\s*\\n\\s\\*\\s@ngdoc method\\n(\\s\\*.*(?<!methodOf)\\n)*\\s\\*\\\/', 'g')
const str = `/**
* @ngdoc method
* @name app.admin:AuditLogController#auditsWatch
* @methodOf app.admin:AuditLogController
*/
/**
* @ngdoc method
* @name app.admin:AuditLogController#auditsWatch
*/
/**
* @name app.admin:AuditLogController#auditsWatch
*/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}