import re
regex = re.compile(r"\/\*\*\s*\n\s\*\s@ngdoc method\n(\s\*.*(?<!methodOf)\n)*\s\*\/")
test_str = ("/** \n"
" * @ngdoc method\n"
" * @name app.admin:AuditLogController#auditsWatch\n"
" * @methodOf app.admin:AuditLogController\n"
" */\n\n\n"
"/**\n"
" * @ngdoc method\n"
" * @name app.admin:AuditLogController#auditsWatch\n"
" */\n\n\n"
"/**\n"
" * @name app.admin:AuditLogController#auditsWatch\n"
" */")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")