$re = '/([a-zA-Z ])+(?=Picasso)/m';
$str = 'Paloma Picasso
Maya Picasso
Paulo Picasso
Claude Picasso
Steve Ross';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);