re = /([a-zA-Z ])+(?=Picasso)/m
str = 'Paloma Picasso
Maya Picasso
Paulo Picasso
Claude Picasso
Steve Ross'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end