re = /\d{4}\K\d+/m
str = '99999999
12345.66
1234
abc99999999
99999999abc'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result