$re = '/\[\~(.+?)\]/m';
$str = 'Hey can [~darryllee] and [~nguyenquang] take a look at this issue?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);