re = /\[\~(.+?)\]/m
str = 'Hey can [~darryllee] and [~nguyenquang] take a look at this issue?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end