using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!\/cantbe\b).)*$";
string input = @"this/is/ok/filename.tr
this/is/ok/cantbe/this/filename.tr
this/is/ok/cantbex/this/filename.tr";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}