$re = '/^((?!\/cantbe\b).)*$/m';
$str = 'this/is/ok/filename.tr
this/is/ok/cantbe/this/filename.tr
this/is/ok/cantbex/this/filename.tr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);