$re = '/((?:(\w+)(?!(?1)).\g{2}))/ix';
$str = 'bbbabbb mnonopoao
# ono and oao doesn\'t match!!!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);