re = /((?:(\w+)(?!(?1)).\g{2}))/ix
str = 'bbbabbb mnonopoao
# ono and oao doesn\'t match!!!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end