package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z\@\#\$]*\d{0,1}[A-Za-z\@\#\$]*$`)
var str = `ab3c
a@bc
a@1c
4
a2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}