import re
regex = re.compile(r"^[A-Za-z\@\#\$]*\d{0,1}[A-Za-z\@\#\$]*$", flags=re.MULTILINE)
test_str = ("ab3c\n"
"a@bc\n"
"a@1c\n"
"4\n"
"a2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")