package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`o{2,}`)
var str = `Amazon Google Home Facebook `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}