$re = '/o{2,}/';
$str = 'Amazon Google Home Facebook ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);