$re = '/(?<![A-Z0-9])[A-Z0-9]{20}(?![A-Z0-9])/';
$str = 'AY2QIEOSLITEHZ7JAIKA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);