#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-a----\s{2,}[0-9]\/[0-9]{1,}\/201[0-9]\s{1,}[0-9]{1,}:[0-9]{2} [AP]M\s{2,}[0-9]{2,}\s"
Local $sString = "-a---- 7/30/2017 4:28 PM 201 textfile1.txt" & @CRLF & _
"-a---- 6/9/2016 4:03 PM 44 textfile2.txt" & @CRLF & _
"-a---- 6/22/2017 12:10 PM 137 textfile3.txt" & @CRLF & _
"-a---- 6/6/2017 7:24 PM 8269721 otherfile.com" & @CRLF & _
"-a---- 3/11/2016 4:22 PM 3370 otherfile.bat"
Local $sSubst = " Call Deletefile(MyMaster.ZSVCPATH'\\firmware\\"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)