re = /-a----\s{2,}[0-9]\/[0-9]{1,}\/201[0-9]\s{1,}[0-9]{1,}:[0-9]{2} [AP]M\s{2,}[0-9]{2,}\s/m
str = '-a---- 7/30/2017 4:28 PM 201 textfile1.txt
-a---- 6/9/2016 4:03 PM 44 textfile2.txt
-a---- 6/22/2017 12:10 PM 137 textfile3.txt
-a---- 6/6/2017 7:24 PM 8269721 otherfile.com
-a---- 3/11/2016 4:22 PM 3370 otherfile.bat'
subst = ' Call Deletefile(MyMaster.ZSVCPATH\'\\\\firmware\\\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result