using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bSTRING:\h+""\K[\w-]+(?="")";
string input = @"[TIMETRA-VRTR-MIB::vRtrIfName.22.178] => STRING: ""interface900"" ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}