re = /\bSTRING:\h+"\K[\w-]+(?=")/m
str = '[TIMETRA-VRTR-MIB::vRtrIfName.22.178] => STRING: "interface900" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end