#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https:\/\/www\.serrurierparis0\.com\/([^ \n]*)"
Local $sString = "https://www.serrurierparis0.com/serrurier-paris-1er.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-2eme.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-3eme.html /serrurier-paris-3eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-4eme.html /serrurier-paris-4eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-5eme.html /serrurier-paris-5eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-6eme.html /serrurier-paris-6eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-7eme.html /serrurier-paris-7eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-8eme.html /serrurier-paris-8eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-9eme.html /serrurier-paris-9eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-10eme.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-11eme.html /serrurier-paris-11eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-12eme.html /serrurier-paris-12eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-13eme.html /serrurier-paris-13eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-14eme.html /serrurier-paris-14eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-15eme.html /serrurier-paris-15eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-16eme.html /serrurier-paris-16eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-17eme.html /serrurier-paris-17eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-18eme.html /serrurier-paris-18eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-19eme.html /serrurier-paris-19eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-paris-20eme.html /serrurier-paris-20eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-antony-92160.html /serrurier-antony-92160/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-bagnolet-93170.html /serrurier-bagnolet-93170/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-bonneuil-sur-marne-94380.html /serrurier-bonneuil-sur-marne-94380/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-chevilly-larue-94550.html /serrurier-chevilly-larue-94550/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-choisy-le-roi-94600.html /serrurier-choisy-le-roi-94600/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-creteil-94000.html /serrurier-creteil-94000/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-drancy-93700.html /serrurier-drancy-93700/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-gennevilliers-92230.html /serrurier-gennevilliers-92230" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-ivry-sur-seine-94200.html /serrurier-ivry-sur-seine-94200/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-le-plessis-robinson-92350.html /serrurier-le-plessis-robinson-92350/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-les-lilas-93260.html /serrurier-les-lilas-93260/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-montrouge-92120.html /serrurier-montrouge-92120/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-puteaux-92800.html /serrurier-puteaux-92800/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-romainville-93230.html /serrurier-romainville-93230/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-saint-cloud-92210.html /serrurier-saint-cloud-92210/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-saint-maurice-94410.html /serrurier-saint-maurice-94410/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-sceaux-92330.html /serrurier-sceaux-92330/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-thiais-94320.html /serrurier-thiais-94320/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-villejuif-94800.html /serrurier-villejuif-94800/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-rue-de-chabrol.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-rue-de-la-grange-aux-belles.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-rue-de-l-aqueduc.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-rue-des-recollets.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-rue-d-hauteville.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-rue-du-faubourg-saint-denis.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-rue-du-terrage.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-rue-faubourg-saint-martin.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-rue-la-fayette.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-rue-louis-blanc.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-11-rue-de-charonne.html /serrurier-paris-11eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-12-rue-charenton.html /serrurier-paris-12eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-13-serrurier-rue-tolbiac.html /serrurier-paris-13eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-14-serrurier-rue-alesia.html /serrurier-paris-14eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-15-serrurier-rue-de-lourmel.html /serrurier-paris-15eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-15-serrurier-rue-lecourbe.html /serrurier-paris-15eme/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-romainville-rue-jean-jaures-93230.html /serrurier-romainville-93230/" & @CRLF & _
"https://www.serrurierparis0.com/serrurier-romainville-rue-veuve-aublet-93230.html /serrurier-romainville-93230/" & @CRLF & _
"https://www.serrurierparis0.com/paris-16-serrurier-rue-de-la-pompe.html /serrurier-paris-16eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-17-serrurier-rue-cardinet.html /serrurier-paris-17eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-17-serrurier-rue-legendre.html /serrurier-paris-17eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-18-serrurier-rue-marcadet.html /serrurier-paris-18eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-19-serrurier-rue-de-crimee.html /serrurier-paris-19eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-rue-de-castiglione.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-rue-de-l-amiral-de-coligny.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-rue-des-halles.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-rue-du-louvre.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-rue-du-pont-neuf.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-rue-montmartre.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-rue-rivoli.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-rue-rohan.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-rue-saint-denis.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-rue-saint-honore.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-20-serrurier-rue-des-pyrenees.html /serrurier-paris-20eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-serrurier-rue-d-aboukir.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-serrurier-rue-de-clery.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-serrurier-rue-du-quatre-septembre.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-serrurier-rue-du-sentier.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-serrurier-rue-d-uzes.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-serrurier-rue-leopold-bellan.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-serrurier-rue-notre-dame-des-victoires.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-serrurier-rue-poissonniere.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-serrurier-rue-saint-denis.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-serrurier-rue-saint-sauveur.html /serrurier-paris-2eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-3-serrurier-rue-du-vertbois.html /serrurier-paris-3eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-3-serrurier-rue-froissart.html /serrurier-paris-3eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-3-serrurier-rue-saint-martin.html /serrurier-paris-3eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-4-serrurier-rue-de-rivoli.html /serrurier-paris-4eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-4-serrurier-rue-de-turenne.html /serrurier-paris-4eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-4-serrurier-rue-du-temple.html /serrurier-paris-4eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-5-serrurier-rue-saint-jacques.html /serrurier-paris-5eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-6-serrurier-rue-de-rennes.html /serrurier-paris-6eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-7-serrurier-rue-de-l-universite.html /serrurier-paris-7eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-8-serrurier-rue-faubourg-saint-honore.html /serrurier-paris-8eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-9-rue-la-fayette.html /serrurier-paris-9eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-17-serrurier-avenue-de-villiers.html /serrurier-paris-17eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-19-serrurier-avenue-jean-jaures.html /serrurier-paris-19eme/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-serrurier-avenue-du-general-lemonnier.html /serrurier-paris-1er/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-serrurier-boulevard-de-magenta.html /serrurier-paris-10eme/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-porte-paris.html /ouverture-de-porte/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-1.html /ouverture-de-porte-paris-1/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-10.html /ouverture-de-porte-paris-10/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-11.html /ouverture-de-porte-paris-11/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-12.html /ouverture-de-porte-paris-12/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-13.html /ouverture-de-porte-paris-13/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-14.html /ouverture-de-porte-paris-14/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-15.html /ouverture-de-porte-paris-15/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-16.html /ouverture-de-porte-paris-16/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-17.html /ouverture-de-porte-paris-17/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-18.html /ouverture-de-porte-paris-18/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-19.html /ouverture-de-porte-paris-19/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-2.html /ouverture-de-porte-paris-2/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-20.html /ouverture-de-porte-paris-20/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-3.html /ouverture-de-porte-paris-3/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-4.html /ouverture-de-porte-paris-4/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-5.html /ouverture-de-porte-paris-5/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-6.html /ouverture-de-porte-paris-6/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-7.html /ouverture-de-porte-paris-7/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-8.html /ouverture-de-porte-paris-8/" & @CRLF & _
"https://www.serrurierparis0.com/ouverture-de-porte-paris-9.html /ouverture-de-porte-paris-9/" & @CRLF & _
"https://www.serrurierparis0.com/paris-10-depannage-volet-roulant.html /reparation-volet-roulant/" & @CRLF & _
"https://www.serrurierparis0.com/paris-1-depannage-volet-roulant.html /reparation-volet-roulant/" & @CRLF & _
"https://www.serrurierparis0.com/paris-2-depannage-volet-roulant.html /reparation-volet-roulant/" & @CRLF & _
"https://www.serrurierparis0.com/faq.html /faq/" & @CRLF & _
"https://www.serrurierparis0.com/faq-percer-une-serrure.html /faq/comment-percer-une-serrure/" & @CRLF & _
"https://www.serrurierparis0.com/faq-comment-decaper-une-serrure-rouillee-sans-la-demonter.html /faq/comment-decaper-une-serrure-rouillee-sans-la-demonter/" & @CRLF & _
"https://www.serrurierparis0.com/faq-ameliorer-l-isolation-de-votre-porte-d-entree.html /faq/comment-ameliorer-lisolation-de-votre-porte-dentree/" & @CRLF & _
"https://www.serrurierparis0.com/faq-comment-remplacer-une-serrure.html /faq/comment-remplacer-une-serrure/" & @CRLF & _
"https://www.serrurierparis0.com/faq-installer-un-judas.html /faq/comment-installer-un-juda/" & @CRLF & _
"https://www.serrurierparis0.com/faq-decaper-une-porte.html /faq/comment-decaper-une-porte/" & @CRLF & _
"https://www.serrurierparis0.com/faq-comment-entretenir-une-serrure.html /faq/comment-entretenir-une-serrure/" & @CRLF & _
"https://www.serrurierparis0.com/faq-comment-changer-un-cylindre-de-serrure.html /faq/comment-changer-un-cylindre-de-serrure/" & @CRLF & _
"https://www.serrurierparis0.com/faq-poser-un-verrou-de-baie-coulissante.html /faq/comment-poser-un-verrou-de-baie-coulissante/" & @CRLF & _
"https://www.serrurierparis0.com/faq-que-faire-en-cas-de-cle-cassee-dans-la-serrure.html /faq/que-faire-en-cas-de-cle-cassee-dans-la-serrure/" & @CRLF & _
"https://www.serrurierparis0.com/faq-quoi-faire-quand-la-serrure-est-bloquee.html /faq/quoi-faire-quand-la-serrure-est-bloquee/" & @CRLF & _
"https://www.serrurierparis0.com/faq-poser-une-serrure-3-points.html /faq/comment-poser-une-serrure-3-points/" & @CRLF & _
"https://www.serrurierparis0.com/faq-que-faire-en-cas-de-cambriolage.html /faq/que-faire-en-cas-de-cambriolage/" & @CRLF & _
"https://www.serrurierparis0.com/faq-retirer-les-gonds-d-une-porte.html /faq/comment-retirer-les-gonds-d-une-porte/" & @CRLF & _
"https://www.serrurierparis0.com/faq-installer-une-porte-d-entree.html /faq/comment-installer-une-porte-d-entree/" & @CRLF & _
"https://www.serrurierparis0.com/faq-changer-le-sens-d-ouverture-d-une-porte.html /faq/comment-changer-le-sens-d-ouverture-d-une-porte/" & @CRLF & _
"https://www.serrurierparis0.com/faq-comment-degivrer-une-serrure-gelee.html /faq/comment-degivrer-une-serrure-gelee/" & @CRLF & _
"https://www.serrurierparis0.com/faq-comment-ouvrir-une-porte-claquee.html /faq/comment-ouvrir-une-porte-claquee/" & @CRLF & _
"https://www.serrurierparis0.com/faq-poser-un-verrou.html /faq/comment-poser-un-verrou/" & @CRLF & _
"https://www.serrurierparis0.com/faq-demonter-une-poignee-de-porte.html /faq/comment-demonter-une-poignee-de-porte/" & @CRLF & _
"https://www.serrurierparis0.com/en/ /en/" & @CRLF & _
"https://www.serrurierparis0.com/en.html /en/" & @CRLF & _
"https://www.serrurierparis0.com/it/ /" & @CRLF & _
"https://www.serrurierparis0.com/it.html /" & @CRLF & _
"https://www.serrurierparis0.com/ru/ /" & @CRLF & _
"https://www.serrurierparis0.com/ru.html /" & @CRLF & _
"https://www.serrurierparis0.com/mentions-legales.html /mentions-legales/" & @CRLF & _
"https://www.serrurierparis0.com/it/mentions-legales.html /it/mentions-legales/" & @CRLF & _
"https://www.serrurierparis0.com/en/mentions-legales.html /en/mentions-legales/" & @CRLF & _
"https://www.serrurierparis0.com/ru/mentions-legales.html /ru/mentions-legales/" & @CRLF & _
"https://www.serrurierparis0.com/tarifs.html /tarifs/" & @CRLF & _
"https://www.serrurierparis0.com/trouver-un-serrurier.html /"
Local $sSubst = "RedirectMatch 301 ^$1$"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)