const regex = /(?<!\d)(?!000|666|9)(order\W?number)?\W*(?<!x)\d{3}[ .=-]{0,10}(?!000)\d{3}[ .=-]{0,10}(?!000)\d{3}/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)(?!000|666|9)(order\\W?number)?\\W*(?<!x)\\d{3}[ .=-]{0,10}(?!000)\\d{3}[ .=-]{0,10}(?!000)\\d{3}', 'gim')
const str = `x123456789
X123456789
x123-456-789
X123-456-789
123-456-789
ordernumber123-456-789
order number123-456789
order number 123456789
123-456789
123456789
ordernumber-123456787
ordernumber - 123456789
ordernumber #123456789
ordernumber !@#\$%^&123456789
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}