import re
regex = re.compile(r"(?<!\d)(?!000|666|9)(order\W?number)?\W*(?<!x)\d{3}[ .=-]{0,10}(?!000)\d{3}[ .=-]{0,10}(?!000)\d{3}", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("x123456789\n"
"X123456789\n"
"x123-456-789\n"
"X123-456-789\n"
"123-456-789\n\n"
"ordernumber123-456-789\n"
"order number123-456789\n"
"order number 123456789\n"
"123-456789\n"
"123456789\n"
"ordernumber-123456787\n"
"ordernumber - 123456789\n"
"ordernumber #123456789\n"
"ordernumber !@#$%^&123456789\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")