package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)This is ([^]*?) sentence`)
var str = `This is just
a simple sentence`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}