import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[((\\w+)\\b[^]]*)\\]((?>(?!\\[\\2\\b).|(?R))*)\\[\\/\\2]";
final String string = "[html style=\"font-size: 18px;\" dir=\"ltr\"][div style=\"font-size: 18px;\" dir=\"ltr\"][p style=\"font-weight: bold;\"]Hello,[/p][p]You have got a new message from [a href=\"https://www.example.com/\"]Example.com[/a][br][br].You could check your message on [a href=\"https://www.example.com/en/manager/inbox.html\"]Manager[/a][/p][p][img src=\"https://www.example.com/assets/images/logo-default-120x50.png\" width=\"120px\" height=\"80px\"][div style=\"color: #D4192D; font-weight: bold;\"]Example.com Team[/div][/p][/div][/html]\n\n"
+ "[div style=\"font-size: 18px;\" dir=\"ltr\"][p style=\"font-weight: bold;\"]Hello,[/p][p]You have got a new message from [a href=\"https://www.example.com/\"]Example.com[/a][br][br].You could check your message on [a href=\"https://www.example.com/en/manager/inbox.html\"]Manager[/a][/p][p][img src=\"https://www.example.com/assets/images/logo-default-120x50.png\" width=\"120px\" height=\"80px\"][div style=\"color: #D4192D; font-weight: bold;\"]Example.com Team[/div][/p][/div]\n\n"
+ "You have got a new message from [a href=\"https://www.example.com/\"]Example.com[/a][br][br].You could check your message on [a href=\"https://www.example.com/en/manager/inbox.html\"]Manager[/a]";
final String subst = "<$1>$3</$2>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}