$re = '/Text\([^)]*\)(?![^}]*?\.appFont)[^}]*}/m';
$str = 'Text("blah")
.appFont(.body)
}
Text("blah")
}
Text(
"blah"
)
.appFont(.blah)
}
Text("blah").appFont(.foo)}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);