$re = '/^((?!src\/app\.js).)*$/m';
$str = 'src/app.js
src/anotherone.js
libs/modules.js
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);