re = /^((?!src\/app\.js).)*$/m
str = 'src/app.js
src/anotherone.js
libs/modules.js
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end