use strict;
my $str = '# Abracadabra
![[Abracadabra/Abracadabra_image1.png]]
![[Abracadabra/secondFolder/Abracadabra_image2.png]]
![[Abracadabra/secondFolder/Abracadabra_image99.png]]
See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]';
my $regex = qr/!\[\[.*\/(.*_image[0-9]{1,2}\.png)\]\]/mp;
my $subst = '![image]\\($1\\)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";