$re = '/!\[\[.*\/(.*_image[0-9]{1,2}\.png)\]\]/m';
$str = '# Abracadabra
![[Abracadabra/Abracadabra_image1.png]]
![[Abracadabra/secondFolder/Abracadabra_image2.png]]
![[Abracadabra/secondFolder/Abracadabra_image99.png]]
See also [[abracadabra2]] and /some other stuff./ [[End of line See image elsewhere.]]';
$subst = "![image]\($1\)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;