const regex = /^(?:3[47]|(\d{2}))\d{13}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:3[47]|(\\d{2}))\\d{13}$', 'gm')
const str = `331234567890123
141234567890123
971234567890123
341234567890123
371234567890123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}